Harvest Forecast is built on modern technologies, and you’ll need a modern browser to use it. If your browser isn’t listed here, it may work fine with Forecast, but we’re not offering official support.

We recommend using the current stable version of Google Chrome. It’s fast, updates itself automatically, and works great on all platforms. 

We also support the current version of Mozilla Firefox, Apple Safari 9+, and Internet Explorer 11+.